Feeds:
Posts
Comments

Archive for March, 2013

Esses dias assinei um plano 3G da Vivo. Chegando em casa, comecei a usar a conexão 3G ao invés do ADSL que tenho aqui para testar o serviço. Foi meio broxante quando depois de um tempo de uso (1 hora talvez? não sei) a conexão ficou extremamente lenta, com pings de 30 segundos ou mais (o recorde foi 200 segundos!). Lá vou eu, ligar pro suporte da Vivo no mesmo dia em que assinei o serviço. A 1ª impressão foi pro ralo.

Interessante que o menu do telefone já classifica o usuário por sistema operacional:

Se você usa um computador com Windows, tecle 1.
Se você usa um computador com Mac OS, tecle 2.
Se você usa um computador com Linux, tecle 3.

Legal, eles reconhecem que existem clientes que usam Linux! Teclei 3. A experiência não foi lá tão boa, mas isso não surpreendeu. Obviamente o suporte da Vivo coloca sempre a culpa no seu equipamento e o problema nunca é na rede deles, então pedem pra fazer trocentos procedimentos de configuração e teste antes de cogitarem que eles têm que fazer algo do lado deles.

Mas isso é outra história. O interessante foi o procedimento que ele pediu pra eu fazer. Em primeiro lugar, pediu para abrir um terminal e digitar:

$ sudo echo 1 > /proc/sys/net/ipv6/conf/all/disable_ipv6

Imagine o tempo que levou pra soletrar tudo isso. 🙂

A 1ª coisa que salta aos olhos é que o comando tem um erro típico de quem não manja muito de Linux (quem eles contrataram pra elaborar os procedimentos de Linux deles?!?): o comando “echo 1” rodará como usuário root, mas a parte do “> blah” é feita pelo shell do usuário, portanto vai dar erro de permissão na hora de escrever no disable_ipv6.

Mais impressionante que isso, o atendente pediu pra eu digitar a parte do “$␣”, ou seja ele soletrou “Cifrão, espaço, s, u, d, o, …”.

FacePalm

Quando terminei de digitar o comando (fazendo as alterações necessárias) e apertei enter, ele perguntou se apareceu “Operação bem sucedida”.

NOT-SURE-IF-A-TROLL-OR-JUST-STUPID

Eu expliquei pra ele que quando não aparece nada é porque o comando deu certo então seguimos adiante. A próxima coisa que eu tinha que fazer era reiniciar o computador. Wait wat? Todo esse trabalho soletrando um comando gigante pra editar uma variável no /proc e ele quer que eu reinicie?

mr-bean-irritado

Pra quem não usa ou não manja de Linux (o que não tem problema nenhum, e é até saudável, a menos que você trabalhe com suporte técnico): as alterações no /proc são “efêmeras” e na próxima vez em que o computador é ligado volta tudo como estava antes.

O lado bom da história é que a Vivo suporta Linux. Os atendentes também são surpreendentemente prestativos. Quando o procedimento acima não funcionou (quem diria?), eu fiquei discutindo com o cara outras possibilidades, ele deu algumas sugestões genéricas, inclusive uma que ajudou bastante: o problema talvez fosse que o modem muda de 3G (HSUPA) para 2G (EDGE), e aí fica lento. Passei a reparar nisso e realmente é o que acontece.

Já estou fugindo do assunto mas resumidamente, em outra ligação a atendente mencionou que é possível forçar o modem a ficar só no 3G, e isso poderia resolver o problema. O procedimento que ela tinha era só pro Windows infelizmente mas tá valendo, entrei no Windows. Só que meu modem é da Claro e o “discador” que veio nele também, e ele é ligeiramente diferente do da Vivo. Apesar disso ela ficou um tempão tentando me ajudar, tentando mapear o procedimento que ela tinha pra interface do meu discador. No fim achei a opção e realmente resolveu o problema!

Agora, por que o modem muda pra EDGE? Isso ninguém soube explicar, e ainda não consegui convencer a Vivo a fazer uma revisão na rede dela aqui no meu bairro…

Advertisements

Read Full Post »